const regex = new RegExp('^[^/\\n]+/[^/\\n]+$', 'gm')
const str = `20200507-30g_25d
20200507-30g_25d/ggg
20200507-30g_25d/grn
20200507-30g_25d/ylw
ggg
grn
tre_livelli
tre_livelli/20200507-30g_25d
tre_livelli/20200507-30g_25d/ggg
tre_livelli/20200507-30g_25d/grn
tre_livelli/20200507-30g_25d/ylw
ylw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}