$re = '~^[^/\n]+/[^/\n]+$~m';
$str = '20200507-30g_25d
20200507-30g_25d/ggg
20200507-30g_25d/grn
20200507-30g_25d/ylw
ggg
grn
tre_livelli
tre_livelli/20200507-30g_25d
tre_livelli/20200507-30g_25d/ggg
tre_livelli/20200507-30g_25d/grn
tre_livelli/20200507-30g_25d/ylw
ylw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);