use strict;
my $str = '20200507-30g_25d
20200507-30g_25d/ggg
20200507-30g_25d/grn
20200507-30g_25d/ylw
ggg
grn
tre_livelli
tre_livelli/20200507-30g_25d
tre_livelli/20200507-30g_25d/ggg
tre_livelli/20200507-30g_25d/grn
tre_livelli/20200507-30g_25d/ylw
ylw';
my $regex = qr~^[^/\n]+/[^/\n]+$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}