# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n(?![^<]*<\\/pre>)//gm;t' <<< "<p>Test contennt for regex
with line breaks</p>
<pre>code block
with multi line content
working fine</pre>
<pre class=\"brush:C#\">
test line break before
open paranthesis < is not working fine
line breaks after paranthesis
is accepted
</pre>"