const regex = /\n(?![^<]*<\/pre>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n(?![^<]*<\\\/pre>)', 'gm')
const str = `<p>Test contennt for regex
with line breaks</p>
<pre>code block
with multi line content
working fine</pre>
<pre class="brush:C#">
test line break before
open paranthesis < is not working fine
line breaks after paranthesis
is accepted
</pre>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);