using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*logging)^";
string substitution = @"#";
string input = @"bla bla logging";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}