use strict;
my $str = 'bla bla logging';
my $regex = qr/(?=.*logging)^/p;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";