const regex = /(?=.*logging)^/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*logging)^', 'g')
const str = `bla bla logging`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);