import Foundation
let pattern = #"(?=.*logging)^"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"bla bla logging"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)