package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\/\\]+):(\d+):(\d+)\D*$`)
var str = `at somewhere: \path1\path2\a_file.ts:17:9 something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}