re = /([^\/\\]+):(\d+):(\d+)\D*$/m
str = 'at somewhere: \\path1\\path2\\a_file.ts:17:9 something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end