$re = '/([^\/\\\\]+):(\d+):(\d+)\D*$/m';
$str = 'at somewhere: \\path1\\path2\\a_file.ts:17:9 something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);