// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\/\\]+):(\d+):(\d+)\D*$").unwrap();
let string = "at somewhere: \\path1\\path2\\a_file.ts:17:9 something";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}