package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http:\/\/[A-Za-z0-9\.]*(\/[A-Za-z0-9]*)?\/[A-Za-z0-9]+[0-9]{1}`)
var str = `http://domain.com/something1
http://domain/domain/something2
http://domain/randomgarbage
http://domain/something3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}