$re = '/http:\/\/[A-Za-z0-9\.]*(\/[A-Za-z0-9]*)?\/[A-Za-z0-9]+[0-9]{1}/';
$str = 'http://domain.com/something1
http://domain/domain/something2
http://domain/randomgarbage
http://domain/something3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);