import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/[A-Za-z0-9\\.]*(\\/[A-Za-z0-9]*)?\\/[A-Za-z0-9]+[0-9]{1}";
final String string = "http://domain.com/something1\n"
+ "http://domain/domain/something2\n"
+ "http://domain/randomgarbage\n"
+ "http://domain/something3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}