const regex = /http:\/\/[A-Za-z0-9\.]*(\/[A-Za-z0-9]*)?\/[A-Za-z0-9]+[0-9]{1}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/[A-Za-z0-9\\.]*(\\\/[A-Za-z0-9]*)?\\\/[A-Za-z0-9]+[0-9]{1}', 'g')
const str = `http://domain.com/something1
http://domain/domain/something2
http://domain/randomgarbage
http://domain/something3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}