using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([а-яА-ЯЁё0-9\_-]+|[0-9a-zA-Z\_-]+)$";
string input = @"ваняяяяя";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}