package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([а-яА-ЯЁё0-9\_-]+|[0-9a-zA-Z\_-]+)$`)
var str = `ваняяяяя`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}