const regex = /^([а-яА-ЯЁё0-9\_-]+|[0-9a-zA-Z\_-]+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([а-яА-ЯЁё0-9\\_-]+|[0-9a-zA-Z\\_-]+)$', '')
const str = `ваняяяяя`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}