$re = '/^([а-яА-ЯЁё0-9\_-]+|[0-9a-zA-Z\_-]+)$/';
$str = 'ваняяяяя';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);