import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*span[^>]*>(.*?)<\\s*\\/\\s*span\\s*>";
final String string = "<p nameIt=\"Title\">Title_Test</p><figure class=\"t15\"><table><thead><tr>\n"
+ "<th><span>Column1</span></th><th><span>Column2</span></th></tr></thead><tbody><tr><td><span>Entry1</span></td><td><span>Entry2</span></td><td><span>ready</span></td></tr><tr><td><span style=\"some:style;\">Entry3</span></td><td><span style=\"another:style;\">Entry4</span></td></tr></tbody></table></figure><p ex=\"ready\">!aaa; ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}