const regex = /<\s*span[^>]*>(.*?)<\s*\/\s*span\s*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*span[^>]*>(.*?)<\\s*\\\/\\s*span\\s*>', 'gm')
const str = `<p nameIt="Title">Title_Test</p><figure class="t15"><table><thead><tr>
<th><span>Column1</span></th><th><span>Column2</span></th></tr></thead><tbody><tr><td><span>Entry1</span></td><td><span>Entry2</span></td><td><span>ready</span></td></tr><tr><td><span style="some:style;">Entry3</span></td><td><span style="another:style;">Entry4</span></td></tr></tbody></table></figure><p ex="ready">!aaa; `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}