#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?=0?(?:(?:4|6|9|11)\/(?:[0-2]?\d|30)|(?:[13578]|1[02])\/(?:[0-2]?\d|3[01])|(?:2)\/(?:[0-2]?\d))\b)(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b"
Local $sString = "MATCH:" & @CRLF & _
"3/26/24" & @CRLF & _
"11/26/24" & @CRLF & _
"1/2/03" & @CRLF & _
"4/05/2006" & @CRLF & _
"12/31/1600" & @CRLF & _
"2/29/24" & @CRLF & _
"10/31/20" & @CRLF & _
"04/30/30" & @CRLF & _
"" & @CRLF & _
"NO MATCH:" & @CRLF & _
"13/2/55" & @CRLF & _
"10/32/20" & @CRLF & _
"2/30/24" & @CRLF & _
"4/31/30"
Local $sSubst = "${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)