import Foundation
let pattern = #"\b(?=0?(?:(?:4|6|9|11)\/(?:[0-2]?\d|30)|(?:[13578]|1[02])\/(?:[0-2]?\d|3[01])|(?:2)\/(?:[0-2]?\d))\b)(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
MATCH:
3/26/24
11/26/24
1/2/03
4/05/2006
12/31/1600
2/29/24
10/31/20
04/30/30
NO MATCH:
13/2/55
10/32/20
2/30/24
4/31/30
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)