$re = '/\b(?=0?(?:(?:4|6|9|11)\/(?:[0-2]?\d|30)|(?:[13578]|1[02])\/(?:[0-2]?\d|3[01])|(?:2)\/(?:[0-2]?\d))\b)(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b/';
$str = 'MATCH:
3/26/24
11/26/24
1/2/03
4/05/2006
12/31/1600
2/29/24
10/31/20
04/30/30
NO MATCH:
13/2/55
10/32/20
2/30/24
4/31/30';
$subst = "${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;