# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?=0?(?:(?:4|6|9|11)\/(?:[0-2]?\d|30)|(?:[13578]|1[02])\/(?:[0-2]?\d|3[01])|(?:2)\/(?:[0-2]?\d))\b)(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b"
test_str = ("MATCH:\n"
"3/26/24\n"
"11/26/24\n"
"1/2/03\n"
"4/05/2006\n"
"12/31/1600\n"
"2/29/24\n"
"10/31/20\n"
"04/30/30\n\n"
"NO MATCH:\n"
"13/2/55\n"
"10/32/20\n"
"2/30/24\n"
"4/31/30")
subst = "${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.