#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0*[1-9]\d*$"
Local $sString = "0" & @CRLF & _
"00" & @CRLF & _
"01" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"123" & @CRLF & _
"999" & @CRLF & _
"1000" & @CRLF & _
"99999999" & @CRLF & _
"a" & @CRLF & _
"a0" & @CRLF & _
"aa" & @CRLF & _
"1a" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")