import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0*[1-9]\\d*$";
final String string = "0\n"
+ "00\n"
+ "01\n"
+ "1\n"
+ "10\n"
+ "123\n"
+ "999\n"
+ "1000\n"
+ "99999999\n"
+ "a\n"
+ "a0\n"
+ "aa\n"
+ "1a\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}