$re = '/^0*[1-9]\d*$/m';
$str = '0
00
01
1
10
123
999
1000
99999999
a
a0
aa
1a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);