package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0*[1-9]\d*$`)
var str = `0
00
01
1
10
123
999
1000
99999999
a
a0
aa
1a
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}