using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Error\.\d+\.Value :(.+?)(?:\\r|\\n|$)";
string input = @"Error.0.Value : This is error for item 0.\r\nError.1.Value : This is error for item 1 and this item is exist.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}