re = /Error\.\d+\.Value :(.+?)(?:\\r|\\n|$)/im
str = 'Error.0.Value : This is error for item 0.\\r\\nError.1.Value : This is error for item 1 and this item is exist.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end