#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\bInvoice[ _:.]+(?<anr>[A-Z/-]*[0-9][A-Z0-9/-]*)(?!\S)"
Local $sString = "Payer:_xxxxxxx" & @CRLF & _
"Waybill Invoice_5IN280625-3/4 Nimetus_EAN " & @CRLF & _
"Invoice issuer: John" & @CRLF & _
"Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte" & @CRLF & _
"vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas." & @CRLF & _
"Kuni Invoice Second280625-3/4 sumiseni k" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")