re = /(?i)\bInvoice[ _:.]+(?<anr>[A-Z\/-]*[0-9][A-Z0-9\/-]*)(?!\S)/
str = 'Payer:_xxxxxxx
Waybill Invoice_5IN280625-3/4 Nimetus_EAN
Invoice issuer: John
Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte
vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas.
Kuni Invoice Second280625-3/4 sumiseni k
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end