use strict;
my $str = 'Payer:_xxxxxxx
Waybill Invoice_5IN280625-3/4 Nimetus_EAN
Invoice issuer: John
Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte
vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas.
Kuni Invoice Second280625-3/4 sumiseni k
';
my $regex = qr/(?i)\bInvoice[ _:.]+(?<anr>[A-Z/-]*[0-9][A-Z0-9/-]*)(?!\S)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}