import Foundation
let pattern = #"(?i)\bInvoice[ _:.]+(?<anr>[A-Z/-]*[0-9][A-Z0-9/-]*)(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Payer:_xxxxxxx
Waybill Invoice_5IN280625-3/4 Nimetus_EAN
Invoice issuer: John
Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte
vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas.
Kuni Invoice Second280625-3/4 sumiseni k
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}