using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Hello World";
string input = @"Hello World , 4435 , Goodbye Moon , 5645 , Hello World , 54354";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}