package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Hello World`)
var str = `Hello World , 4435 , Goodbye Moon , 5645 , Hello World , 54354`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}