re = /Hello World/m
str = 'Hello World , 4435 , Goodbye Moon , 5645 , Hello World , 54354'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end