$re = '/Hello World/m';
$str = 'Hello World , 4435 , Goodbye Moon , 5645 , Hello World , 54354';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);