using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"K(?=Y)([^\/]*?)[0-9]{4}";
string input = @"JKan 1987
KYan this is /uaaaaaaaa 1987
KYanaaa this is aaaaaa 1987";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}