$re = '/K(?=Y)([^\/]*?)[0-9]{4}/';
$str = 'JKan 1987
KYan this is /uaaaaaaaa 1987
KYanaaa this is aaaaaa 1987';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);