re = /K(?=Y)([^\/]*?)[0-9]{4}/
str = 'JKan 1987
KYan this is /uaaaaaaaa 1987
KYanaaa this is aaaaaa 1987'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end