# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d*)( *)(x|\*)/$0/gm;t' <<< "500 g (4 x 125 g)
1,8 kg (20 * 90 g)
380 g (2 x 190 g)
1,6 kg (16 x 100 g)
1,6 kg (226x100 g)
8 x 100 g
2 l"