// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)(\d*)( *)(x|\*)").unwrap();
  let string = "500 g (4 x 125 g)
1,8 kg (20 * 90 g)
380 g (2 x 190 g)
1,6 kg (16 x 100 g)
1,6 kg (226x100 g)
8 x 100 g
2 l";
  let substitution = "$0";
  
  // result will be a String with the substituted value
  let result = regex.replace_all(string, substitution);
  
  println!("{}", result);
}