import Foundation
let pattern = #"(\d*)( *)(x|\*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
500 g (4 x 125 g)
1,8 kg (20 * 90 g)
380 g (2 x 190 g)
1,6 kg (16 x 100 g)
1,6 kg (226x100 g)
8 x 100 g
2 l
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)