use strict;
my $str = '500 g (4 x 125 g)
1,8 kg (20 * 90 g)
380 g (2 x 190 g)
1,6 kg (16 x 100 g)
1,6 kg (226x100 g)
8 x 100 g
2 l';
my $regex = qr/(\d*)( *)(x|\*)/mp;
my $subst = '$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";