import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>(?P<scheme>[^:\\/?#]+):(?=\\/\\/))?(?>\\/\\/)?(?>(?>(?P<login>[^:]+)(?::(?P<password>[^@]+)?)?@)?(?P<host>[^@\\/?#:]*)(?::(?P<port>\\d+)?)?)?(?P<path>[^?#]*)(?>\\?(?P<query>[^#]*))?(?>#(?P<fragment>.*))?";
final String string = "https://ftpuserftp.trong.live:ftp.trong.live@ftp.trong.live:443/prv/test.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}