$re = '/^(?>(?P<scheme>[^:\/?#]+):(?=\/\/))?(?>\/\/)?(?>(?>(?P<login>[^:]+)(?::(?P<password>[^@]+)?)?@)?(?P<host>[^@\/?#:]*)(?::(?P<port>\d+)?)?)?(?P<path>[^?#]*)(?>\?(?P<query>[^#]*))?(?>#(?P<fragment>.*))?/m';
$str = 'https://ftpuserftp.trong.live:ftp.trong.live@ftp.trong.live:443/prv/test.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);